Annoying rattle on cold start - Jeep TrackHawk Forum
 
Thread Tools
post #1 of 5 Old 07-13-2019, 06:12 PM Thread Starter
Senior Member
 
adamkc's Avatar
 
Join Date: Apr 2018
Posts: 196
Annoying rattle on cold start

Recently when I either start my vehicle manually or via remote start I hear a rattle upon startup for the first few seconds. Almost sounds as if the oil pan is loose or something from underneath the front - from the dash forward - but cannot pinpoint the sound. It's very annoying and always happens on a cold start or if the jeep's been sitting for more than 10 minutes.

Anyone else have this?
adamkc is online now  
post #2 of 5 Old 07-13-2019, 06:36 PM
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,164
Sounds like heat shielding maybe
Lil Hemi is online now  
post #3 of 5 Old 07-14-2019, 09:00 AM
Senior Member
 
Car-Guy's Avatar
 
Join Date: Jan 2018
Location: East Texas Countyside
Posts: 254
I doubt that it's the oil pan or you would have and see an oil leak. Could be a lot of things but I've found a few loose bolts on mine during routine maintenance checks. Any of them could have become a rattle at some point. I'd start by checking the engine bay and bottom side for anything that is loose.
Car-Guy is online now  
Sponsored Links
Advertisement
 
post #4 of 5 Old 07-17-2019, 11:41 AM Thread Starter
Senior Member
 
adamkc's Avatar
 
Join Date: Apr 2018
Posts: 196
Quote:
Originally Posted by Car-Guy View Post
I doubt that it's the oil pan or you would have and see an oil leak. Could be a lot of things but I've found a few loose bolts on mine during routine maintenance checks. Any of them could have become a rattle at some point. I'd start by checking the engine bay and bottom side for anything that is loose.
Dealer says it's normal - says it's the hydraulic lifters in the SRT/Hellcat engines and chatter hard until they pump up with oil. Said it doesn't help that we use thin oil. Makes sense, just don't like the noise.

Anyone use other oil that what's recommended?
adamkc is online now  
post #5 of 5 Old 07-17-2019, 11:56 AM
Senior Member
 
Car-Guy's Avatar
 
Join Date: Jan 2018
Location: East Texas Countyside
Posts: 254
Quote:
Originally Posted by adamkc View Post
Dealer says it's normal - says it's the hydraulic lifters in the SRT/Hellcat engines and chatter hard until they pump up with oil. Said it doesn't help that we use thin oil. Makes sense, just don't like the noise.

Anyone use other oil that what's recommended?
I used Mobil 1 0-40 for the first few changes but switched to Penzoil Ultra 0-40 when I found Mobil 1 didn't meet the Hellcat engine specs. Never noticed any rattle/clatter though....
Car-Guy is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome