Seems to be lugging in Auto mode - Jeep TrackHawk Forum
 2Likes
Reply
 
Thread Tools
post #1 of 13 Old 04-13-2019, 03:23 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 10
Seems to be lugging in Auto mode

I am a newbie with just under 1k miles on my 2018. I love the ride but curious if everyone else experiences this scenario. When driving around the city at normal speeds in auto mode it seems like the Trackhawk shifts into a gear to high or maybe locks the converter so that when you step on the gas a nomral amount it is lugging the engine. You can depress the accelerator hard to get out of it but the engine lugging seems like something is wrong to me.
GNXtoWS6 is online now  
Sponsored Links
Advertisement
 
post #2 of 13 Old 04-13-2019, 03:29 PM
Senior Member
 
Join Date: May 2018
Location: Allen, TX
Posts: 373
Have you tried driving it around for 50-60 miles or so in Sport? In Auto, it can be a little lazy, unless you give it half+ throttle and then it will downshift. I drive around in Auto most of the time, and it shifts into 8th gear by 40mph. It seems perfectly content at 1500rpm or so (which might be considered lugging the engine), but I've gotten used to it.

If you don't want it upshifting into a really high gear, put it in Sport and drive it like that... no more lugging.

Current Stable:
'18 Billet Silver Trackhawk
'02 Lingenfelter Twin Turbo Z06
'11 ZR1
'14 Audi SQ5
WA 2 FST is online now  
post #3 of 13 Old 04-13-2019, 03:45 PM
Senior Member
 
Black Track's Avatar
 
Join Date: Jan 2018
Location: Speeding in SoCal
Posts: 341
Dial in the settings for your exact preferences.

I keep everything on track except for suspension which I leave on the softest mode.

This way, the engine and transmission respond lightning quick, but the ride quality remains good.

Current:
2018 Trackhawk black/black
2017 Ferrari 488GTB
1968 Shelby GT500KR

Past:
2014 Grand Cherokee SRT
2006 Corvette ZO6
2005 Dodge Ram SRT-10 Quad Cab
1977 Jeep CJ with 401
1970 Dodge Challenger R/T 440
1970 Dodge Charger R/T 440
1966 Corvette 427
Black Track is online now  
post #4 of 13 Old 04-13-2019, 03:48 PM
Banned
 
Join Date: Dec 2018
Location: west coast
Posts: 267
I'm with black track on the custom setting, but I keep trans in sport not track, otherwise it holds pretty low gears and will have me cruising at 3k rpm.
Quicksilver likes this.
bloodyhellhawk is offline  
post #5 of 13 Old 04-13-2019, 03:52 PM
Senior Member
 
Black Track's Avatar
 
Join Date: Jan 2018
Location: Speeding in SoCal
Posts: 341
Yes, you will need to manually nudge the shifter into 8th gear, with the trans in track mode. It stays in 7th otherwise.

Sport is a good choice too, as bloody said.

Current:
2018 Trackhawk black/black
2017 Ferrari 488GTB
1968 Shelby GT500KR

Past:
2014 Grand Cherokee SRT
2006 Corvette ZO6
2005 Dodge Ram SRT-10 Quad Cab
1977 Jeep CJ with 401
1970 Dodge Challenger R/T 440
1970 Dodge Charger R/T 440
1966 Corvette 427
Black Track is online now  
post #6 of 13 Old 04-13-2019, 04:18 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 10
Great ideas. thank you!
GNXtoWS6 is online now  
post #7 of 13 Old 04-13-2019, 04:46 PM
Senior Member
 
Join Date: May 2018
Location: Allen, TX
Posts: 373
My Custom Mode is trans in Track, Suspension in Auto, Steering in Sport. I'm either in this, or in Auto for cruising. I do _not_ take for granted that we can customize our driving experience for our needs/wants. Very good job by FCA.
Quicksilver likes this.

Current Stable:
'18 Billet Silver Trackhawk
'02 Lingenfelter Twin Turbo Z06
'11 ZR1
'14 Audi SQ5
WA 2 FST is online now  
post #8 of 13 Old 04-13-2019, 05:10 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 10
Is there a way to have it start up in Custom mode or do you always have to select it? I made the changes and it is much better for normal city driving. Auto mode is fine for the highway.
GNXtoWS6 is online now  
post #9 of 13 Old 04-13-2019, 05:16 PM
Senior Member
 
Join Date: May 2018
Location: Allen, TX
Posts: 373
Quote:
Originally Posted by GNXtoWS6 View Post
Is there a way to have it start up in Custom mode or do you always have to select it? I made the changes and it is much better for normal city driving. Auto mode is fine for the highway.
I haven't found a way to have custom (or any other mode) set as default on startup.
WA 2 FST is online now  
post #10 of 13 Old 04-13-2019, 05:27 PM
Senior Member
 
Car-Guy's Avatar
 
Join Date: Jan 2018
Location: East Texas Countyside
Posts: 218
Never experienced any lugging but normal driving speeds for me starts at 70. Very rare for me to drive below 70 for more than a few miles at a time. (Nearest town to me is 15 miles away and it's less than 1000 people.) I do stop for the one flashing stop light in the center of town but then it's back up to 70+ MPH.
Car-Guy is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Start up in Sport Mode rather than Auto Surf City Dan Forum Member Reviews 8 09-21-2018 11:00 PM
Android Auto and Android 9.0 zambonidriver Electronics, Audio, and Lighting 2 08-08-2018 02:28 PM
HP Seems To Top at 600?? CrombieTH 2018+ Jeep Trackhawk General Discussion 25 07-23-2018 03:20 PM
Launch Control - Paddles vs. Auto AlaskaMatt 2018+ Jeep Trackhawk General Discussion 3 05-11-2018 01:16 AM
Apple CarPlay and Android Auto Added to Uconnect 4.0 Jeep TrackHawk News 2018+ SRT Trackhawk News 7 01-19-2016 03:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome