Attention Livernois Motorsports - Page 11 - Jeep TrackHawk Forum
 29Likes
Reply
 
Thread Tools
post #101 of 115 Old 10-25-2019, 10:31 AM
Member
 
Join Date: Jun 2018
Posts: 43
The code you threw was a pump module failure. That would burn plugs no matter who's tune you had in the hawk. I think blaming a stock part failure on the tuner is reaching myself.

A pump module failure you cant really blame on them. Hell that would of possibly burned plugs on the stock tune.

I data log and have the livernois tune I use HP tuners to data log Regularly

I saw this posted also on FB Jerod Its kinda a smoking gun what happened. The truck was a WOT for 30 seconds and the pump module failed or overheated and grounded out so one of the pumps shut down and you were still at WOT this caused a lean condition melting the plugs.

I pray that it was only the plugs! Scope the motor, And no matter what check the pumps and module regardless of what tune you run on it

Last edited by Geno; 10-25-2019 at 11:24 AM.
Geno is offline  
Sponsored Links
Advertisement
 
post #102 of 115 Old 10-25-2019, 12:39 PM Thread Starter
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,520
I’m not saying it’s the tune’s fault, I am saying that from what I hear I’m not the only Livernois tuned jeep to have this problem. Multiple different tuners said the plugs Livernois supplies with the S1025 kit are too hot. I am definitely saying those two things. I’m busy the next few days but I’ll get it inspected by Monday. It seemed fine after the ignition cycle so I’ve got some hope. Wish me luck that nothings screwed but the missing ceramic from one of the plugs has me worried.
ROCKETW19 likes this.
Lil Hemi is online now  
post #103 of 115 Old 10-25-2019, 12:48 PM
Member
 
Join Date: Jun 2018
Posts: 43
Quote:
Originally Posted by Lil Hemi View Post
Im not saying its the tunes fault, I am saying that from what I hear Im not the only Livernois tuned jeep to have this problem. Multiple different tuners said the plugs Livernois supplies with the S1025 kit are too hot. I am definitely saying those two things. Im busy the next few days but Ill get it inspected by Monday. It seemed fine after the ignition cycle so Ive got some hope. Wish me luck that nothings screwed but the missing ceramic from one of the plugs has me worried.
Fingers crossed brother!!

I used my own plugs 2 steps colder.

Check that pump module as the second pump only comes on after a set fuel amount is commanded. The truck could run perfect but the pump or module could still be bad
Geno is offline  
post #104 of 115 Old 10-25-2019, 01:18 PM Thread Starter
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,520
I think I’ll be adding to the fuel system, just to be on the safe side.
Lil Hemi is online now  
post #105 of 115 Old 10-25-2019, 02:04 PM
Super Moderator
 
Join Date: Jan 2019
Posts: 848
you going BAP or actual system? what about ID1700s?
P026A is fuel pressure and common code if pump goes out. how long have you had the TH? the newer THs have a new pump from a different supplier and this problem is fixed.

30 seconds at WOT holly smokes was it still pulling at 160? 160 is fast, be safe
ROCKETW19 is online now  
post #106 of 115 Old 10-25-2019, 02:27 PM Thread Starter
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,520
I’m not sure yet, 160 cured my need for speed for the moment. It was still pulling pretty hard too. First things first, need to assess the problem and see where I stand, then I’ll figure out where to sell a kidney, then we’ll get it fixed up.
ROCKETW19 and Jimmy N. like this.
Lil Hemi is online now  
post #107 of 115 Old 10-26-2019, 09:40 AM
Senior Member
 
Join Date: Nov 2018
Posts: 154
Quote:
Originally Posted by ROCKETW19 View Post
you going BAP or actual system? what about ID1700s?
P026A is fuel pressure and common code if pump goes out. how long have you had the TH? the newer THs have a new pump from a different supplier and this problem is fixed.

30 seconds at WOT holly smokes was it still pulling at 160? 160 is fast, be safe

Interesting info. Thanks for sharing. Care to share more detail on that updated/new secondary pump? Should we (guys who have modded cars similar to Lil Hemi) consider switching to that new one ot go along with the moto of if it ain't broke, don't fix it.
Back to OP's point, I agree with him that Livernois should step up and refund the trans tune. Good will goes a long way.
emericr is offline  
post #108 of 115 Old 10-27-2019, 04:36 AM
Super Moderator
 
Join Date: Jan 2019
Posts: 848
Quote:
Originally Posted by emericr View Post
Interesting info. Thanks for sharing. Care to share more detail on that updated/new secondary pump? Should we (guys who have modded cars similar to Lil Hemi) consider switching to that new one ot go along with the moto of if it ain't broke, don't fix it.
Back to OP's point, I agree with him that Livernois should step up and refund the trans tune. Good will goes a long way.
its factory pump the newer hell cats trachawks already have them installed
other then that I am clueeless what to do. im gonna run it till it brakes
ROCKETW19 is online now  
post #109 of 115 Old 10-28-2019, 12:53 AM Thread Starter
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,520
Just spoke with a member from hellcat.org and he took his to Livernois and reports a Lean condition as well. I encouraged him to join this conversation. Hopefully Livernois will continue to engage in this discussion and we can figure out what’s going on with these jeeps and get the problem solved before anyone else has damage.
emericr likes this.

Last edited by Lil Hemi; 11-25-2019 at 07:29 PM.
Lil Hemi is online now  
post #110 of 115 Old 12-18-2019, 05:32 PM Thread Starter
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,520
Well no surprise here, Livernois never bothered to continue the discussion. I would definitely recommend staying away from this company.
Lil Hemi is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome