Belts broke on 20k mile th - Jeep TrackHawk Forum
 2Likes
Reply
 
Thread Tools
post #1 of 15 Old 06-17-2019, 12:54 PM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 5
Belts broke on 20k mile th

Was driving and all of a sudden Throttle body alarm goes off and Engine light. I look to see my temps pinned at the top. I pull over to see this under the hood. The belt broke and tore the other serpentine belt odd as well. Ohhh also wrapped around the coolant line and tore that out... Happy Fathers Day .
Attached Thumbnails
Click image for larger version

Name:	51F36A9F-511B-4A0F-AB32-06C3AA316A9D (1).JPG
Views:	99
Size:	951.7 KB
ID:	6300  
SENNAONE is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 06-17-2019, 01:52 PM
Senior Member
 
Join Date: May 2017
Posts: 151
Is this all covered under the 36k mile warranty? i have to assume this is.
scottiekay1973 is offline  
post #3 of 15 Old 06-17-2019, 02:03 PM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 5
Quote:
Originally Posted by scottiekay1973 View Post
Is this all covered under the 36k mile warranty? i have to assume this is.
It will be. I am also asking for them to extend this on the life of my lease which is 2 more years.
SENNAONE is offline  
post #4 of 15 Old 06-17-2019, 02:11 PM
Senior Member
 
Join Date: May 2018
Location: Allen, TX
Posts: 403
Happened to me, 2 months into ownership, at under 2000 miles.

Here's the thread, and what FCA told me: https://www.jeeptrackhawk.org/forum/...-stranded.html

Current Stable:
'18 Billet Silver Trackhawk
'02 Lingenfelter Twin Turbo Z06
'11 Corvette ZR1
'14 Audi SQ5
WA 2 FST is online now  
post #5 of 15 Old 06-17-2019, 05:43 PM
Senior Member
 
adamkc's Avatar
 
Join Date: Apr 2018
Posts: 197
Quote:
Originally Posted by SENNAONE View Post
Was driving and all of a sudden Throttle body alarm goes off and Engine light. I look to see my temps pinned at the top. I pull over to see this under the hood. The belt broke and tore the other serpentine belt odd as well. Ohhh also wrapped around the coolant line and tore that out... Happy Fathers Day .
Happened to me as well with only 13K miles. No recall yet but my dealer said the part # changes on the supercharger indicating a known issue/bad belt with the first ones off the line. I went with a Gates heavier duty belt this time around.
adamkc is online now  
post #6 of 15 Old 06-17-2019, 06:04 PM
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,176
I found mine was off a rib at the SC from the factory but I’ve heard of a few people having theirs snap. No idea if they’d verified the belt was on correctly before their belt failures though.
Lil Hemi is online now  
post #7 of 15 Old 06-18-2019, 06:56 PM
Member
 
gooweea's Avatar
 
Join Date: Dec 2017
Posts: 66
Happened to me with about 250 miles on mine.
gooweea is offline  
post #8 of 15 Old 06-20-2019, 10:26 PM
Member
 
chad951's Avatar
 
Join Date: Jun 2019
Posts: 45
Garage
Quote:
Originally Posted by gooweea View Post
Happened to me with about 250 miles on mine.
Going on the first long distance road trip next weekend and while towing my trailer so I'm ditching the factory SC belt. I just ordered a Gates HD belt today. It will be nice to have piece of mind on my trip. I know it isn't rational due to the low numbers of failures. Just call me paranoid but better safe than sorry. I already have my first issue. I checked the trailer today and the brand new tire, that I replaced last year, is flat. I wasn't going to chance this luck. :/
adamkc likes this.

2018 Trackhawk - Bright White - Loaded
1989 Porsche 944 Turbo
2001 Audi S8 - 6 speed manual
chad951 is offline  
post #9 of 15 Old 06-22-2019, 11:23 AM
Junior Member
 
Join Date: Apr 2019
Posts: 16
Part numbers for the accessory belt is Gates K060832HD


Blower drive is K100579HD


Installed both yesterday, just in case. The Hellcat acc belt with PS is a touch longer, I think it works but this number fits nice an snug with tensioner

dbrisson is offline  
post #10 of 15 Old 06-22-2019, 11:31 AM
Senior Member
 
Join Date: May 2018
Location: Allen, TX
Posts: 403
Quote:
Originally Posted by chad951 View Post
Going on the first long distance road trip next weekend and while towing my trailer so I'm ditching the factory SC belt. I just ordered a Gates HD belt today. It will be nice to have piece of mind on my trip. I know it isn't rational due to the low numbers of failures. Just call me paranoid but better safe than sorry. I already have my first issue. I checked the trailer today and the brand new tire, that I replaced last year, is flat. I wasn't going to chance this luck. :/
Its easy/cheap insurance. After I had mine towed to the dealer and they put brand new belts on it, I got it home and installed some Gates HD green belts. No issues in 10 months since, but I have some new factory belts, just in case.
WA 2 FST is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome