Low Battery Light - Jeep TrackHawk Forum
 1Likes
  • 1 Post By 30birdy99
 
Thread Tools
post #1 of 8 Old 06-22-2019, 02:03 PM Thread Starter
Senior Member
 
Join Date: Oct 2018
Location: AZ
Posts: 124
Low Battery Light

So the battery light has come on 3 times over the last week. The battery gauge is showing 13.3V when running, regardless of lights, AC, radio or engine speed. Voltmeter shows the same and the alternator belt is tight. I'm guessing it is the voltage regulator and where do you suppose FCA put it? Yep, the worst possible place, in the PCM. Made an appointment to get it checked out next week. I am glad I don't have a tune in it. Anybody else ever have this failure yet?

1999 30th Anniversary Trans Am, 416 Cu. In.
2007 Toyota X-Runner, TRD Supercharged
2007 Tblaze SS, Slammed and Cammed
30birdy99 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 06-22-2019, 08:41 PM
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 960
A few people have had issue with the infotainment system staying on after the vehicle shuts off. Could be your issue.
Lil Hemi is online now  
post #3 of 8 Old 07-01-2019, 05:18 PM Thread Starter
Senior Member
 
Join Date: Oct 2018
Location: AZ
Posts: 124
Just got back from the dealer and they confirmed that the PCM is bad. I hope this isn't a common failure since a lot of these trucks are tuned. That would cost the PCM and a new tune in addition to the down time. Yikes.
ROCKETW19 likes this.

1999 30th Anniversary Trans Am, 416 Cu. In.
2007 Toyota X-Runner, TRD Supercharged
2007 Tblaze SS, Slammed and Cammed
30birdy99 is offline  
post #4 of 8 Old 07-12-2019, 11:17 PM Thread Starter
Senior Member
 
Join Date: Oct 2018
Location: AZ
Posts: 124
After confiding in my local dealer, which has no level 3 techs, here is the story of what happened. The PCM was replaced and it too failed within an hour of leaving the service department. Back to the dealer and alternator was found to be at fault. So another PCM and alternator were installed. Check engine light comes on within 10 minutes of leaving the service department again. It appears they didn't perform all of the relearn procedures required after a PCM swap. It finally made it back home tonight so I hope all is well now. I wish the next closest dealer wasn't 90 miles away.

1999 30th Anniversary Trans Am, 416 Cu. In.
2007 Toyota X-Runner, TRD Supercharged
2007 Tblaze SS, Slammed and Cammed
30birdy99 is offline  
post #5 of 8 Old 07-12-2019, 11:39 PM
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 960
So frustrating!
Lil Hemi is online now  
post #6 of 8 Old 07-15-2019, 09:11 PM Thread Starter
Senior Member
 
Join Date: Oct 2018
Location: AZ
Posts: 124
A few hundred miles and a dozen re starts nd all is still well. I wonder since my PCM was changed by the dealer under warranty if it shows the 1400 code? Hmmmm

1999 30th Anniversary Trans Am, 416 Cu. In.
2007 Toyota X-Runner, TRD Supercharged
2007 Tblaze SS, Slammed and Cammed
30birdy99 is offline  
post #7 of 8 Old 07-15-2019, 10:49 PM
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 960
No, if they changed it, then it shouldn’t still throw codes. I’m guessing they have some way to reset it.
Lil Hemi is online now  
post #8 of 8 Old 07-16-2019, 02:19 PM
Super Moderator
 
Join Date: Jan 2019
Posts: 584
I was gonna say alternator is the problem when I first read it.
then you said it was the PCM i figured ok but was glad to see thats not it, lol
sucks you had to do all this drama over a shitty dealer or tech.
ROCKETW19 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome