Smoking on startup? - Jeep TrackHawk Forum
 
Thread Tools
post #1 of 4 Old 07-23-2019, 01:55 PM Thread Starter
Senior Member
 
Join Date: Jul 2019
Location: Indiana
Posts: 154
Smoking on startup?

Hey guys,

So i just picked up a new 2018 TH last Saturday. It currently has about 1200 miles on it now and when I first start it after sitting a while, it blew a huge puff of blue smoke (oil burn) out the tailpipes. This is the first time i have seen it do that but it doesnt mean it hasn't happened before also.

Is this normal for being new or could there be an issue?

Thanks

2002 Honda S2000 (fully built turbo beast)
2009 Acura MDX
2011 M3 ZCP
2018 Trackhawk (Rhino)
Spoolin is online now  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-23-2019, 01:57 PM
Senior Member
 
Join Date: May 2017
Posts: 166
I get the same thing every now and again. Wondered the same if its normal. Truck still screws!
scottiekay1973 is offline  
post #3 of 4 Old 07-23-2019, 02:03 PM
Super Moderator
 
Lil Hemi's Avatar
 
Join Date: Mar 2018
Posts: 1,324
Search a thread called blue smoke
Lil Hemi is online now  
post #4 of 4 Old 07-23-2019, 02:04 PM Thread Starter
Senior Member
 
Join Date: Jul 2019
Location: Indiana
Posts: 154
I'll check it out, thanks.

2002 Honda S2000 (fully built turbo beast)
2009 Acura MDX
2011 M3 ZCP
2018 Trackhawk (Rhino)
Spoolin is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome