Trackhawk doesn’t move - Jeep TrackHawk Forum
 18Likes
Reply
 
Thread Tools
post #1 of 28 Old 07-26-2019, 12:41 AM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 10
Trackhawk doesn’t move

So decided to push it a little on the highway switched it to track mode and I hit about 150mph and my check engine light came on. I came to the stoplight and when it came time to go it wouldn’t move . Tried switching from park to reverse to drive and nothing! Loud noise and vibration when changing to drive, reverse and car doesn’t move even if I give it gas. Had to call a tow and I’m waiting now. I just got my car last week and only has 470 miles on it. I’m so pissed!!! Have no idea what it is.
Matthewleal is offline  
post #2 of 28 Old 07-26-2019, 06:32 AM
Member
 
Join Date: Jul 2019
Location: Indiana
Posts: 79
Quote:
Originally Posted by Matthewleal View Post
So decided to push it a little on the highway switched it to track mode and I hit about 150mph and my check engine light came on. I came to the stoplight and when it came time to go it wouldnt move . Tried switching from park to reverse to drive and nothing! Loud noise and vibration when changing to drive, reverse and car doesnt move even if I give it gas. Had to call a tow and Im waiting now. I just got my car last week and only has 470 miles on it. Im so pissed!!! Have no idea what it is.

I have no clue other than maybe the gear selector at the trans may have malfunctioned and not properly engaging. Don't fret too much though, warranty will cover it, whatever it is.

2002 Honda S2000 (fully built turbo beast)
2009 Acura MDX
2011 M3 ZCP
2018 Trackhawk (Rhino)
Spoolin is online now  
post #3 of 28 Old 07-26-2019, 07:48 AM
Member
 
Join Date: Dec 2018
Posts: 55
well..according to the news..a peep from new hampshire got pulled over doing 145 in a 65..so..at least you didnt get arrested like him
ROCKETW19 likes this.
PaulWells18# is online now  
Sponsored Links
Advertisement
 
post #4 of 28 Old 07-26-2019, 09:57 AM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 10
Thanks, they are checking on it now, will keep you posted
Matthewleal is offline  
post #5 of 28 Old 07-26-2019, 11:14 AM
Super Moderator
 
Join Date: Jan 2019
Posts: 543
Quote:
Originally Posted by Matthewleal View Post
Thanks, they are checking on it now, will keep you posted
super curious what happened. please update us when you hear.
no noise no nothing just dont work is weird but makes me think its something super easy like a plug came un-plugged or something silly. I hope so at least.
Spoolin likes this.
ROCKETW19 is offline  
post #6 of 28 Old 07-26-2019, 02:05 PM
Senior Member
 
Car-Guy's Avatar
 
Join Date: Jan 2018
Location: East Texas Countyside
Posts: 229
Sure sounds like something with the transmission or transfer case to me. Hopefully something minor like an electrical connection or software anomaly/error. I've never topped mine out but I've seen 150+ more than once and no issues. Smooth, stable and plenty to go.
Car-Guy is online now  
post #7 of 28 Old 07-26-2019, 06:20 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 10
So they said it’s the valve body, it’s an electrical part (brain) of the transmission. I looked on YouTube and there are some tutorials, Doesn’t seem that complicated to fix they just pull the pan from underneath the trans and it should be right inside. Only thing that bothers me is 470miles on the car I just picked it up last week so this soon having issues is kind of upsetting. I think this May be a common issue with a lot of jeeps though.

Just wanted to inform you guys I’ll let you know when I get it back how it runs.
Matthewleal is offline  
post #8 of 28 Old 07-26-2019, 06:34 PM
Super Moderator
 
Join Date: Jan 2019
Posts: 543
the fact it dont have lot of miles in this case should be good. meaning its just a bad part to start. nothing messed it up its just bad. dont stress on it.
gooweea and Spoolin like this.
ROCKETW19 is offline  
post #9 of 28 Old 07-26-2019, 09:54 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 10
Yes your right, thanks!! Can’t wait to get it back they gave me a wrangler which actually I’m enjoying I removed roof and windows 😁 enjoying the breeze this weekend in New York haha
Spoolin likes this.
Matthewleal is offline  
post #10 of 28 Old 07-27-2019, 10:54 AM
Senior Member
 
Join Date: Oct 2018
Location: AZ
Posts: 123
I think it sounds like it will turn out OK. I too, had a significant failure with very low miles. Better now than without the warranty and at least they gave you a loner.

1999 30th Anniversary Trans Am, 416 Cu. In.
2007 Toyota X-Runner, TRD Supercharged
2007 Tblaze SS, Slammed and Cammed
30birdy99 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome