Transmission problems - Jeep TrackHawk Forum
 4Likes
  • 1 Post By ThawkMike
  • 1 Post By Black Track
  • 1 Post By ThawkMike
  • 1 Post By ThawkMike
 
Thread Tools
post #1 of 10 Old 09-29-2019, 08:42 PM Thread Starter
Member
 
Broken98's Avatar
 
Join Date: Oct 2018
Location: MI
Posts: 90
Wink Transmission problems

Just wondering whats going on with my transmission as of the last 100miles. Im an 18 all stock with about 8800 miles . I live in mi and its gotten a little cooler here. 1 afternoon i had been driving my jeep for about 45min in traffic when i noticed it started to shift a lil wierd. I noticed that the 1rst to second gear shifts feel laggy like to much shift extension. I also notice it doesnt feel as snappy when i tip in the throttle. It seems to rev up higher almost to get it moving . It has been this way for the last 100miles or so . It still shifts just doesnt have the precision it had at lower speeds . It also feels like its not as responsive . Its almost like the gear selection isnt right. Just wanted to see if anyone has expierenced this. Truck still feels fast once its moving just doesnt feel the same. Anyone notice anything along these lines . It feels like something isnt right. Thanks sorry for the long post
Broken98 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 09-29-2019, 10:28 PM
Senior Member
 
Join Date: Oct 2018
Posts: 388
There is a trans reflash for the 2018 that covers some of those converter issues you mentioned.

Mine does this as well at times. Ive learned to live with it by stepping into the gas more or just ignoring it.


Sent from my iPhone using Tapatalk
Broken98 likes this.
ThawkMike is online now  
post #3 of 10 Old 09-29-2019, 11:23 PM Thread Starter
Member
 
Broken98's Avatar
 
Join Date: Oct 2018
Location: MI
Posts: 90
Theres a re -flash thats good to to hear. I just dont understand why started doing outa nowhere. But i guess i should take it in.
Broken98 is offline  
post #4 of 10 Old 09-30-2019, 10:49 AM
Senior Member
 
Join Date: May 2017
Posts: 166
is the reflash something in the past 3 months?
scottiekay1973 is offline  
post #5 of 10 Old 09-30-2019, 12:24 PM
Senior Member
 
Black Track's Avatar
 
Join Date: Jan 2018
Location: Speeding in SoCal
Posts: 388
Are you sure that your transmission settings are still in the sport mode...perf pages stuff.
Broken98 likes this.

Current:
2018 Trackhawk black/black
2017 Ferrari 488GTB
1968 Shelby GT500KR
1966 Cobra 427 replica

Past:
2014 Grand Cherokee SRT
2008 Porsche 911 Turbo
2006 Corvette ZO6
2005 Dodge Ram SRT-10 Quad Cab
1977 Jeep CJ with 401
1970 Dodge Challenger R/T 440
1970 Dodge Charger R/T 440
1966 Corvette 427
Black Track is offline  
post #6 of 10 Old 09-30-2019, 12:42 PM
Senior Member
 
Join Date: Oct 2018
Posts: 388
Transmission problems

Quote:
Originally Posted by scottiekay1973 View Post
is the reflash something in the past 3 months?


The reflash was something a few guys had done in 2018, that I know of.


Sent from my iPhone using Tapatalk
Broken98 likes this.
ThawkMike is online now  
post #7 of 10 Old 09-30-2019, 12:44 PM
Senior Member
 
Join Date: Oct 2018
Posts: 388
Transmission problems

Quote:
Originally Posted by Black Track View Post
Are you sure that your transmission settings are still in the sport mode...perf pages stuff.


It doesnt do it sport or track, just auto. Its a torque converter slip or gear change flared shift if you have ever had a trans start going on you.


Assuming OP is talking about same thing I am.

Sent from my iPhone using Tapatalk
Broken98 likes this.

Last edited by ThawkMike; 09-30-2019 at 01:01 PM.
ThawkMike is online now  
post #8 of 10 Old 09-30-2019, 06:45 PM Thread Starter
Member
 
Broken98's Avatar
 
Join Date: Oct 2018
Location: MI
Posts: 90
So im reading this right there is some sort of software re fladh for this . Thanks all in advance.
Broken98 is offline  
post #9 of 10 Old 10-11-2019, 01:13 AM
Member
 
Join Date: Dec 2018
Location: Burlington, WI
Posts: 30
I have the same issue. Its a bit annoying. Agree started out of nowhere.
Docholliday is offline  
post #10 of 10 Old 10-11-2019, 09:40 AM
Member
 
Join Date: Dec 2018
Posts: 65
Quote:
Originally Posted by Docholliday View Post
I have the same issue. Its a bit annoying. Agree started out of nowhere.
-WEIRD...other day..my TH wouldnt shift properly..got stuck in gear..just weird sh*t..
turned it off..re started..worked fine..but trannie light on dash came on..made an appt..to take her in ..(a few days out)..the morning of my appt...trannie light off...just weird stuff..
PaulWells18# is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep TrackHawk Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome