Jeep TrackHawk Forum banner

101 - 117 of 117 Posts

·
Registered
Joined
·
43 Posts
The code you threw was a pump module failure. That would burn plugs no matter who's tune you had in the hawk. I think blaming a stock part failure on the tuner is reaching myself.

A pump module failure you cant really blame on them. Hell that would of possibly burned plugs on the stock tune.

I data log and have the livernois tune I use HP tuners to data log Regularly

I saw this posted also on FB Jerod Its kinda a smoking gun what happened. The truck was a WOT for 30 seconds and the pump module failed or overheated and grounded out so one of the pumps shut down and you were still at WOT this caused a lean condition melting the plugs.

I pray that it was only the plugs! Scope the motor, And no matter what check the pumps and module regardless of what tune you run on it
 

·
Super Moderator
Joined
·
1,711 Posts
Discussion Starter #102
I’m not saying it’s the tune’s fault, I am saying that from what I hear I’m not the only Livernois tuned jeep to have this problem. Multiple different tuners said the plugs Livernois supplies with the S1025 kit are too hot. I am definitely saying those two things. I’m busy the next few days but I’ll get it inspected by Monday. It seemed fine after the ignition cycle so I’ve got some hope. Wish me luck that nothings screwed but the missing ceramic from one of the plugs has me worried.
 

·
Registered
Joined
·
43 Posts
I’m not saying it’s the tune’s fault, I am saying that from what I hear I’m not the only Livernois tuned jeep to have this problem. Multiple different tuners said the plugs Livernois supplies with the S1025 kit are too hot. I am definitely saying those two things. I’m busy the next few days but I’ll get it inspected by Monday. It seemed fine after the ignition cycle so I’ve got some hope. Wish me luck that nothings screwed but the missing ceramic from one of the plugs has me worried.
Fingers crossed brother!!

I used my own plugs 2 steps colder.

Check that pump module as the second pump only comes on after a set fuel amount is commanded. The truck could run perfect but the pump or module could still be bad
 

·
Super Moderator
Joined
·
1,001 Posts
you going BAP or actual system? what about ID1700s?
P026A is fuel pressure and common code if pump goes out. how long have you had the TH? the newer THs have a new pump from a different supplier and this problem is fixed.

30 seconds at WOT holly smokes was it still pulling at 160? 160 is fast, be safe
 

·
Super Moderator
Joined
·
1,711 Posts
Discussion Starter #106
I’m not sure yet, 160 cured my need for speed for the moment. It was still pulling pretty hard too. First things first, need to assess the problem and see where I stand, then I’ll figure out where to sell a kidney, then we’ll get it fixed up.
 

·
Registered
Joined
·
157 Posts
you going BAP or actual system? what about ID1700s?
P026A is fuel pressure and common code if pump goes out. how long have you had the TH? the newer THs have a new pump from a different supplier and this problem is fixed.

30 seconds at WOT holly smokes was it still pulling at 160? 160 is fast, be safe

Interesting info. Thanks for sharing. Care to share more detail on that updated/new secondary pump? Should we (guys who have modded cars similar to Lil Hemi) consider switching to that new one ot go along with the moto of if it ain't broke, don't fix it.
Back to OP's point, I agree with him that Livernois should step up and refund the trans tune. Good will goes a long way.
 

·
Super Moderator
Joined
·
1,001 Posts
Interesting info. Thanks for sharing. Care to share more detail on that updated/new secondary pump? Should we (guys who have modded cars similar to Lil Hemi) consider switching to that new one ot go along with the moto of if it ain't broke, don't fix it.
Back to OP's point, I agree with him that Livernois should step up and refund the trans tune. Good will goes a long way.
its factory pump the newer hell cats trachawks already have them installed
other then that I am clueeless what to do. im gonna run it till it brakes
 

·
Super Moderator
Joined
·
1,711 Posts
Discussion Starter #109 (Edited)
Just spoke with a member from hellcat.org and he took his to Livernois and reports a Lean condition as well. I encouraged him to join this conversation. Hopefully Livernois will continue to engage in this discussion and we can figure out what’s going on with these jeeps and get the problem solved before anyone else has damage.
 

·
Super Moderator
Joined
·
1,711 Posts
Discussion Starter #110
Well no surprise here, Livernois never bothered to continue the discussion. I would definitely recommend staying away from this company.
 

·
Super Moderator
Joined
·
1,711 Posts
Discussion Starter #112
What happened about what? I’m not understanding what it is you’re asking.
 

·
Super Moderator
Joined
·
1,001 Posts
No problem with my 1025,but they did the install not some idiot.
LOL, lil hemi did the install and i doubt hes a idiot besides the point any monkey with tools can do it unbolt one part bolt on another. install is never the issue. I have not read one single problem from anyone's install. it is ALWAYS the tune. ALWAYS
 

·
Super Moderator
Joined
·
1,711 Posts
Discussion Starter #116
Not yet, I think it’s one of the fuel pumps on Its last leg. I’ve been too busy to really give it any attention lately. I’ve been looking for someone fairly local to un-Livernois my Jeep and I finally found someone so I’m thinking I’ll just hand it over and let them do everything at once.
 

·
Registered
Joined
·
15 Posts
In this day and age you have to hit them on social media. Facebook, Instagram, Twitter. Leave bad reviews, keep hounding them. Bad comments hurt their bottom line, and the bottom line is always $$. Also, email is going away like the floppy disk. Try Facebook Messenger.
 
101 - 117 of 117 Posts
Top