Jeep TrackHawk Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
So, I've been playing around... and I get a lot of weird results. 3.3 at 2500rpm in track mode. 3.8 in auto mode at 2200 but with 3 people in the car.


Curious as to what the best launch control setup is... including suspension, brake pressure, rpm at launch, etc. Thanks guys!
 

·
Banned
Joined
·
362 Posts
I haven't played around with launch control at all, "yet", but my first power braking run was 0-60 in 3.1 and the 1/4 in 11.5 @ 119. That was done in track mode with about 2000 to 2200 rpm power braking. Since that was done on my first serious attempt, I'm sure I can do better with some practice and under better conditions.
 

·
Banned
Joined
·
362 Posts
OK, I've only done 7 or 8 runs so far but my best times have been with traction control off, and in track mode. However, with all 4 wheels initially slipping/ spinning it's limiting my 0-60 times to 3.3 to 3.4 range (worse has been 3.5 and that was in auto mode w/o any power braking) "But" I have found (duh) that if I launch from a concrete surface (rather than asphalt) I don't get nearly as much wheel spin and I can get 3.1. (I guess that's surface prep in the real would :wink2:). Also, similar to my SRT's, I am seeing my best times with cooler air temps. I'm also wondering if there are better street tires for launching?

Next, I think I'm going to try some Sunoco 260GT or Plus and see if that makes any difference. Or maybe just add an octane booster? Anyone have any experience with either a higher octane fuel or octane booster?
 

·
Registered
Joined
·
15 Posts
My best 0-60 time was also in track mode and no launch control (3.0) ... best time in launch control was (3.4), maybe I'm doing something wrong.
 

·
Registered
Joined
·
411 Posts
Slightly different animal, I know, but on my '15 SRT both stock and after I put a supercharger on it, I got best results just holding brake, giving a little throttle to load the drivetrain and just stomping the gas. Using LC was fun, but it usually was .1-.2 slower on that vehicle (and it was a 0-60 in 3.6-3.8 with the supercharger).

I have not tried LC on my TH yet (have heard the cruise control recall issue may create the same problem when using LC, so that has me a little nervous). I did make some runs pre 500 miles, and now I'm at 615 miles. In TRACK mode, 0-60 in 3.4-3.5 in 85^F heat and a full tank of gas, just holding the brake, revving to ~1500+ and mashing the gas. Very consistent this way. I expect times to dip into the 3.2-3.3 range once the fall/winter hits and we get some temps in the 35-45^F range (assuming traction is still there on cold pavement).
 
1 - 7 of 7 Posts
Top