Jeep TrackHawk Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1 (Edited)
Hey TH Folks -

Since i've been locked up in the house for the past few weeks, I have hardly been driving my Hawk. It sat for a solid week without being driven / started so the battery died on me...

Ended up jumpstarting the hawk and came across two issues after doing so.

First problem, Got a check engine light.

Second problem, My headunit / radio / Uconnect whatever you wan't to call it is dead with a black screen.

Everything in the car works fine expect my headunit. Checked fuses, but everything seems fine but wasn't too sure which fuse is connected to the headunit.

Just got done driving it around again and the check engine light is gone, but radio / headunit is still dead.

Any ideas what could be my issue? Anything will help!

Thanks!
 

·
Registered
Joined
·
78 Posts
Discussion Starter #2
If anyone was wondering...Yes, I have tried power button, screen button, and a few soft-resets but nothing seems to work.

Location of the headunit fuse would be great if anyone knows where it's at.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #4
My man...You just saved me $170 bucks lol. Stealership was going to charge me just to look at the problem. Thank you, it worked!!!
 

·
Super Moderator
Joined
·
1,249 Posts
Try disconnecting the battery give it a minutes or two n reconnect.
honestly this fixes most issues. lmao it fixes most issues with everything. If your TV stops working or gets stuck just unplug it for a few mins, if your chick is talking back just knock her ass out for a few mins when she wakes back up she will be fixed.
 

·
Super Moderator
Joined
·
1,249 Posts
My man...You just saved me $170 bucks lol. Stealership was going to charge me just to look at the problem. Thank you, it worked!!!
I have his paypal info you can just send the $70 and call it good.

lol sorry I am just trying to have fun. FB is full of idiots and I am sick of politics and Virus talk.
 

·
Super Moderator
Joined
·
2,015 Posts
Battery isn’t that bad to disconnect. No need to do both terminals, just scoot the seat forward a bit and go at it from the backseat. Use a 10mm to loosen n slide off. Shouldn’t take more than 30 seconds. Now, putting in a new battery is a little more involved.
 

Attachments

·
Super Moderator
Joined
·
2,015 Posts
Actually, make payments to Pietz Performance lol. New engine is honed n being balanced. Hoping to get it built and installed soon but I’m guessing mid May before the jeep is ready to drive. 🤞🏻 It’s sooner than then!!!
 

·
Registered
Joined
·
78 Posts
Discussion Starter #10
I have his paypal info you can just send the $70 and call it good.

lol sorry I am just trying to have fun. FB is full of idiots and I am sick of politics and Virus talk.
HAH! May have to chat with my chick...
Battery isn’t that bad to disconnect. No need to do both terminals, just scoot the seat forward a bit and go at it from the backseat. Use a 10mm to loosen n slide off. Shouldn’t take more than 30 seconds. Now, putting in a new battery is a little more involved.
I’m an idiot...I put the seat all the way back and used a ratcheting wrench to get the negative terminal off lol. Did not cross my mind to push the seat up to get better rear access. You live and you learn.
 

·
Super Moderator
Joined
·
2,015 Posts
This forum is great for all kinds of stuff like that. We don’t let A-holes on here so everyone is pretty chill and helpful.
 
1 - 11 of 11 Posts
Top