Jeep TrackHawk Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Last Friday I was 5 min from arriving home and getting ready for a great weekend. Neither happened. Coasted to a safe area as quickly as I could. Pop the hood to find what appears to be trans fluid all over the engine bay, mostly passenger side. Not a good feeling watching smoke pour from engine/underneath and hoping nothing is hot enough to start a fire.

Been sitting at dealer ship since Sat. Seriously considering having it towed home in hopes it's something like the quick-connect fitting wasn't properly seated at the factory so I can fix this myself. But I have no idea of the condition of the transmission.

Even if the dealer gets around to looking at it, I'm certain if it is able to move once they find the leak and fill it, they are going to say the trans is 100% good! But in the back of my mind I will always wonder when will this come back and bite me in the ass?
 

·
Super Moderator
Joined
·
225 Posts
These vehicles run a hot pink colored coolant. Maybe it’s coolant instead of trans fluid??
Coolant looks purple to me.... :grin2:>:)
 

·
Super Moderator
Joined
·
1,950 Posts
Not the IC coolant, the engine coolant. My 14 had the water pump go out and was leaking onto the ground. Having never seen pink coolant before, I incorrectly assumed tranny fluid. My Evo runs a blue coolant, I guess nobody uses the green stuff anymore.
 

·
Super Moderator
Joined
·
225 Posts
Not the IC coolant, the engine coolant. My 14 had the water pump go out and was leaking onto the ground. Having never seen pink coolant before, I incorrectly assumed tranny fluid. My Evo runs a blue coolant, I guess nobody uses the green stuff anymore.
IC coolant and Engine coolant are the same....

p/n 68163848AB (concentrate) / p/n 68163849AB (50/50 mixture)
 

·
Super Moderator
Joined
·
1,950 Posts
Well that’s good to know that they’re the same (hadn’t looked into it). I think it’s the lighting conditions that make it look purple. It looks more pinkish when I looked directly at the coolant with the cap off.

Just a hopeful thought that it’s coolant. Just seems like that would be a much easier fix with little to no damage as long as he shut it down before it got too hot.

Best of luck with it and please keep us posted with the diagnosis.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #7
I wish it was coolant. Definitely transmission fluid. Unique smell when burning (on hot exhaust manifolds). Was 5 min from home, so only going 35 or so when I started looking for the quickest place to pull over. Felt it surge (buck) a bit while pulling over, I assume that was the trans losing enough pressure to hold gear? Trans oil, engine oil, and coolant temps showed no signs of overheating just before I shut her off.


3 working days and 0% progress.
Called and started a case with SRT.
 

·
Registered
Joined
·
96 Posts
Both of my coolant's (IC and engine) are purple on my Trackhawk. My Hellcat has purple IC coolant and orange engine coolant. Both have the same part number but they could be different colors.
 

·
Registered
Joined
·
67 Posts
Last Friday I was 5 min from arriving home and getting ready for a great weekend. Neither happened. Coasted to a safe area as quickly as I could. Pop the hood to find what appears to be trans fluid all over the engine bay, mostly passenger side. Not a good feeling watching smoke pour from engine/underneath and hoping nothing is hot enough to start a fire.

Been sitting at dealer ship since Sat. Seriously considering having it towed home in hopes it's something like the quick-connect fitting wasn't properly seated at the factory so I can fix this myself. But I have no idea of the condition of the transmission.

Even if the dealer gets around to looking at it, I'm certain if it is able to move once they find the leak and fill it, they are going to say the trans is 100% good! But in the back of my mind I will always wonder when will this come back and bite me in the ass?


Same thing happened to me at 666 miles. Tranny fluid is clear with a green tint.
 

·
Registered
Joined
·
67 Posts
Any updates on your issue?
I was told by the dealer the hose was not put on at the factory correctly. They kept it for 3 days running tests and cleaning. was told there was no damage because once I had oil blow through the passenger hood vent all over the windshield and smoke rolling out every where I pulled into a parking lot and shut it down and watched the fluid pour out of the front end.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #14
I was told by the dealer the hose was not put on at the factory correctly. They kept it for 3 days running tests and cleaning. was told there was no damage because once I had oil blow through the passenger hood vent all over the windshield and smoke rolling out every where I pulled into a parking lot and shut it down and watched the fluid pour out of the front end.
Thanks for posting! Unfortunately I could feel the trans slipping just prior to finding a safe spot.

They are trying to replace the hose assembly (I think) but can't get the part. 19 days and counting...
 

·
Registered
Joined
·
147 Posts
Thanks for posting! Unfortunately I could feel the trans slipping just prior to finding a safe spot.

They are trying to replace the hose assembly (I think) but can't get the part. 19 days and counting...
Have you tried contacting Jeep Support directly?
 

·
Registered
Joined
·
37 Posts
Discussion Starter #16
Have you tried contacting Jeep Support directly?
Yes, got them involved 2 weeks ago. Same message, we are trying to find out what parts are ordered so we can expedite...


on a more positive note, still loving your Demonized TH?
 

·
Registered
Joined
·
67 Posts
Thanks for posting! Unfortunately I could feel the trans slipping just prior to finding a safe spot.

They are trying to replace the hose assembly (I think) but can't get the part. 19 days and counting...
That is crazy. I told them if there was any damage with that low of miles to get me a new one. They agreed.
 

·
Registered
Joined
·
695 Posts
It’s unreal how totally unprepared FCA is with servicing these issues. I can’t imagine how hard parts will be to come by in several years, especially if this is a one or two year run, which is what it’s looking like.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #19
So the part they are waiting on is a transmission. I can say the 16 days and 178 miles of ownership was pretty awesome though! And that is with me still babying it breaking it in.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #20
Back on the road. New trans, trans cooler/condenser and lines.
 

Attachments

1 - 20 of 25 Posts
Top