Jeep TrackHawk Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
68 Posts
Started the car this morning and noticed that coolant temp wasn’t registering on performance pages. Seemed to be working on the dash gauge. Anyone else have this issue?



I had a similar issue with the gauges in the performance pages not being in sync with the same gauge on the dash they ended up replacing the whole unit and now it works fine
 

Attachments

·
Registered
Joined
·
113 Posts
I had a similar issue with the gauges in the performance pages not being in sync with the same gauge on the dash they ended up replacing the whole unit and now it works fine
Looking at those pictures you have more problems than just the gauges...You steering wheel was installed on the wrong side!..........LOL

On a serious note I have noticed many times the gauges on the dash would not be the same as the gauges on the performance pages. Usually just a point or two....I have also noticed this on prior vehicles I have owned.
 

·
Registered
Joined
·
68 Posts
Do the Aussie-market TH's come with the Trackhawk badge on the dashboard, and the SRT wheel, or did you do those?

I changed the Steering wheel air bag to SRT as I didn't like the JEEP logo. and it came with the Trackhawk badge.



There was a limited edition here in OZ for the release of the Trackhawk into Australia, it was called the Launch Edition and was limited to 62 vehicles and that badge has your build number. Mine is 54 of 62
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top