Jeep TrackHawk Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
I've noticed that after a short drive on my "daily route" of about 5 miles, all under 50mph, when I get to where I'm going, I park, leave the TH running, go in, and when I come out, the cooling fan is screaming on High.

The Water Temp Gauge never gets to, or even goes over half way, no Warning Lights on, TH runs and drives perfectly fine, fan isn't on WHILE driving, no smell of coolant, nothing funky going on at all.

Does anyone else's do this, or is this just how these are?
 

·
Banned
Joined
·
362 Posts
I never noticed in my 2018 TH but I have in my 2019 TH since day one. Sounds like a jet engine kicking in an afterburner... Typically I've only noticed it when it's hot outside and I pull up and stop at a light, or park with the engine running. Maybe 15 or 20sec and then it goes back to a normal speed.
 

·
Registered
Joined
·
408 Posts
I've noticed that after a short drive on my "daily route" of about 5 miles, all under 50mph, when I get to where I'm going, I park, leave the TH running, go in, and when I come out, the cooling fan is screaming on High.

The Water Temp Gauge never gets to, or even goes over half way, no Warning Lights on, TH runs and drives perfectly fine, fan isn't on WHILE driving, no smell of coolant, nothing funky going on at all.

Does anyone else's do this, or is this just how these are?
In Sport mode or Track mode it assumes the engine will be used to the max so the fan is on to help the cooling process. It usually doesn't kick on as much in Auto mode. Do you have it in Sport/Track or a custom setting where the transmission is set to Sport or Track? If so, when you park flip it back to auto and the fan won't kick on as much if it bothers you.
 

·
Registered
Joined
·
376 Posts
my truck does the same the fan is on and screaming after any drive no matter what mode. I wasn't sure if my tuner had adjusted the settings of the fan to something different due to the engine mod's I have and for added cooling. But I experience the same thing. I chalked it up to normal.
 

·
Registered
Joined
·
246 Posts
Yup it’s normal, toggle through screen displays and set the coolant temp in display and watch as coolant climbs past 207* and you’ll hear the fans come on in a low speed and as coolant temp rises so will fan speed/noise increase and when it gets to 213* or so the fan speed will be max high and howling.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #6 ·
In Sport mode or Track mode it assumes the engine will be used to the max so the fan is on to help the cooling process. It usually doesn't kick on as much in Auto mode. Do you have it in Sport/Track or a custom setting where the transmission is set to Sport or Track? If so, when you park flip it back to auto and the fan won't kick on as much if it bothers you.
This is it! It's my Custom Mode Config...never woulda thought about that.

Thanks peeps.
 
1 - 6 of 6 Posts
Top