Jeep TrackHawk Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've got 220 mile on my Trackhawk. I picked it in December. The first time I drove it had a metal rubbing noise from the left front suspension area when I loaded it into a right turn off ramp. I put the vehicle on a lift and have found the transmission cooler line bolt was missing from the clamp, further the trans casting has no threads for a bolt? The trans shifter cable looks to have aftermarket ZIP TIES installed on it. Then the AC hoses were rubbing on the strut tower. I still have not found the noise. Any help out there?
 

·
Registered
Joined
·
67 Posts
There is a TSB about a heat shield rubbing. They state to loosen the engine mounts and push engine as far right as possible. Mine is going in on Monday and I am having them fix this. I have a squeaking noise coming from the front left on slow braking and slow turns.
 

·
Registered
Joined
·
8 Posts
Window/Trim Issue Too

Same issue regarding the metal rubbing noise. My Trackhawk has been at the dealer since Monday. I'm currently having this issue, the fuel line recall, and a window installation problem addressed. When they manufactured the car they did not push the window in all the way so I had ice wedging underneath the trim. This is very frustrating, but hopefully will be resolved today or tomorrow. I attached a picture of the window/trim issue. I've also noticed this on quite a few photos and videos of other Trackhawks online. This probably is not as big of an issue in a warm weather climate as it is here in Chicago. However, it does look terrible and make me second-guess my decision to purchase the Trackhawk rather than the Bentayga or maybe even waiting to check out the new Lamborghini Ugly... Oops, I meant Urus.
 
1 - 5 of 5 Posts
Top