Jeep TrackHawk Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have an 2018 Trackhawk, 4000 miles odometer, live in Saudi Arabia at 2000' of altitude and temperature of 104 F.
my best 0-60 is 4.0 sec and the average is 4.4 - 4.5 sec.
On track mode the engine shows all RED.
When I lowered the Launch control to 1200 RPM, the brakes hold but when I release my foot, the tires spin BIG TIME, that could explain the 4.4 sec.
On youtube, trackhawks there launch silently, no spins.
How can I hit lower than 4.0 sec?
 

·
Registered
Joined
·
408 Posts
What tires are you on?
I have an 2018 Trackhawk, 4000 miles odometer, live in Saudi Arabia at 2000' of altitude and temperature of 104 F.
my best 0-60 is 4.0 sec and the average is 4.4 - 4.5 sec.
On track mode the engine shows all RED.
When I lowered the Launch control to 1200 RPM, the brakes hold but when I release my foot, the tires spin BIG TIME, that could explain the 4.4 sec.
On youtube, trackhawks there launch silently, no spins.
How can I hit lower than 4.0 sec?
I would say your elevation and high temps play a role so you may not get the 3.1-3.5 we see here in the states.
 

·
Super Moderator
Joined
·
1,443 Posts
I have an 2018 Trackhawk, 4000 miles odometer, live in Saudi Arabia at 2000' of altitude and temperature of 104 F.
my best 0-60 is 4.0 sec and the average is 4.4 - 4.5 sec.
On track mode the engine shows all RED.
When I lowered the Launch control to 1200 RPM, the brakes hold but when I release my foot, the tires spin BIG TIME, that could explain the 4.4 sec.
On youtube, trackhawks there launch silently, no spins.
How can I hit lower than 4.0 sec?
spinning is causing slow times for sure. 104 is hot but not crazy hot. your just spining tires to much,
skip the stupid launch learn how to press the gas just hard enough to take off hard but not spin. it takes a few tries but really not that long. Never just smash the gas unless you are on a prepped track that might work there but on street no way learn to drive it.
 

·
Registered
Joined
·
8 Posts
spinning is causing slow times for sure. 104 is hot but not crazy hot. your just spining tires to much,
skip the stupid launch learn how to press the gas just hard enough to take off hard but not spin. it takes a few tries but really not that long. Never just smash the gas unless you are on a prepped track that might work there but on street no way learn to drive it.
Let some air out of your tires. Try 20 psi.
 
1 - 8 of 8 Posts
Top