Jeep TrackHawk Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
234 Posts
Discussion Starter #1
So the battery light has come on 3 times over the last week. The battery gauge is showing 13.3V when running, regardless of lights, AC, radio or engine speed. Voltmeter shows the same and the alternator belt is tight. I'm guessing it is the voltage regulator and where do you suppose FCA put it? Yep, the worst possible place, in the PCM. Made an appointment to get it checked out next week. I am glad I don't have a tune in it. Anybody else ever have this failure yet?
 

·
Super Moderator
Joined
·
1,711 Posts
A few people have had issue with the infotainment system staying on after the vehicle shuts off. Could be your issue.
 

·
Registered
Joined
·
234 Posts
Discussion Starter #3
Just got back from the dealer and they confirmed that the PCM is bad. I hope this isn't a common failure since a lot of these trucks are tuned. That would cost the PCM and a new tune in addition to the down time. Yikes.
 
  • Like
Reactions: ROCKETW19

·
Registered
Joined
·
234 Posts
Discussion Starter #4
After confiding in my local dealer, which has no level 3 techs, here is the story of what happened. The PCM was replaced and it too failed within an hour of leaving the service department. Back to the dealer and alternator was found to be at fault. So another PCM and alternator were installed. Check engine light comes on within 10 minutes of leaving the service department again. It appears they didn't perform all of the relearn procedures required after a PCM swap. It finally made it back home tonight so I hope all is well now. I wish the next closest dealer wasn't 90 miles away.
 

·
Registered
Joined
·
234 Posts
Discussion Starter #6
A few hundred miles and a dozen re starts nd all is still well. I wonder since my PCM was changed by the dealer under warranty if it shows the 1400 code? Hmmmm
 

·
Super Moderator
Joined
·
1,711 Posts
No, if they changed it, then it shouldn’t still throw codes. I’m guessing they have some way to reset it.
 

·
Super Moderator
Joined
·
1,001 Posts
I was gonna say alternator is the problem when I first read it.
then you said it was the PCM i figured ok but was glad to see thats not it, lol
sucks you had to do all this drama over a shitty dealer or tech.
 
1 - 8 of 8 Posts
Top