Jeep TrackHawk Forum banner

1 - 20 of 105 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1 (Edited)
So I finally got past the dreaded 500 mile mark. I made some late night 0-60 runs with the result of no better than 5 seconds... After reviewing the Dyno performance page I noticed it won't go over about 410HP... Visited the dealer today and they had no resolution other to set up a Chrysler Rep to come see the vehicle. It is throwing off no codes, they flashed it, and still no luck. Their description was the same as mine, it felt almost like it was in Valet mode, except 1st gear is active, so are all the other features like launch control. They told me to use the Valet mode a few times while I work to get a meeting set up with the Rep to see if it fixes itself.

Just curious if anyone else has seen or heard or dealt with something like this...

Thanks
 

·
Registered
Joined
·
361 Posts
No problem here. Clearly something is wrong. You should be able to break 5 at about half throttle and no power braking... I have!

I haven't looked the the Dyno pages to see what it's telling me but I will the next time I make a serious run.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
So today they told me that I have to have 1500 miles for access to all horsepower, or 18 hours. I have just now hit 1100 miles which is over 18 hours so once I get to 1500 hopefully the problem will be solved. I have to say though I am concerned since the flier that was wrapped around the passenger sun visor said 500 miles. Wondering if they have made some changes to the software for recent released vehicles. That is the only thing that would make sense to me at this point.
 

·
Registered
Joined
·
361 Posts
I don't buy the 1500 mile explanation either but I've heard stranger things. I don't remember the exact mileage when I made my first serious run but it was under 1500 miles. Probably under 1000. It sounds to me like the throttle just isn't being allowed to open up on yours for some reason. Maybe mechanical or maybe software.

Is you dealer an approved or certified SRT/Hellcat shop?
 

·
Registered
Joined
·
501 Posts
I babied mine until 1200 miles, but even on the day I bought it (with 19 miles on the odometer) it felt instantly more powerful/quicker than the '14 SRT I traded in.

Can you shoot a video of your performance pages dyno when you're doing a full-throttle acceleration run? Would be interesting to see that data.

In the meantime, is there another Jeep dealer nearby that you could go to? I think it's worth getting a second opinion.
 

·
Registered
Joined
·
361 Posts
After reviewing the Dyno performance page I noticed it won't go over about 410HP... Visited the dealer today and they had no resolution other to set up a Chrysler Rep to come see the vehicle.

Just curious if anyone else has seen or heard or dealt with something like this...

Thanks
I brought up the Dyno pages this morning and I made a quick pass on the highway from 60 to ??0:) for just a few seconds. I noticed the line on the graph when up to about 650+HP.
 

·
Registered
Joined
·
501 Posts
Hmmm...judging by the pix you posted, it looks like it revved to 6000 in 2nd, 3rd and 5th, but only to 5000 rpm in 4th.

Did it do that on its own (assuming you were at WOT) or was it a result of traffic conditions and you let off the throttle early on the 4-5 shift?

I'm as perplexed as you are as to why the hp and torque curves plateau at around the 400 mark.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
I was at wide open throttle from about 10 miles an hour to about 60, I shut it down just after hitting 5th. Two SRT Dealers state same thing, sent an email in to FCA yesterday but no response yet.

Joke of the Day courtesy of my mother in law... " I was watching the news today and a Jeep employee at the factory stole a Trackhawk engine and replaced the one in the vehicle with a Dodge Neon engine, and Jeep is trying to track down the owner of the vehicle. She quickly followed up with, Do you think that is why your vehicle is so slow?"
 

·
Registered
Joined
·
695 Posts
I was at wide open throttle from about 10 miles an hour to about 60, I shut it down just after hitting 5th. Two SRT Dealers state same thing, sent an email in to FCA yesterday but no response yet.

Joke of the Day courtesy of my mother in law... " I was watching the news today and a Jeep employee at the factory stole a Trackhawk engine and replaced the one in the vehicle with a Dodge Neon engine, and Jeep is trying to track down the owner of the vehicle. She quickly followed up with, Do you think that is why your vehicle is so slow?"
Well look on the bright side,, if your mother in law is right you’ve got yourself a one-off! 😜
 

·
Registered
Joined
·
184 Posts
Your mother in law is a hoot! :D
Maybe you can get another dealership to give you a second opinion? Just in cease they find something the first one doesn't.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #13
Update on this issue. Crossed the 1500 miles as they requested and no improvement just more of the same, short horsepower.

Dropped off at the dealer last Tuesday and issue is not resolved as yet. In that time they spent a lot of time talking with Engineers in Detroit. Most everything done revolved around software. After going back and forth the only item they could find was that the computer registered mine with 17" rims and evidently there was a handful of vehicles that left that way and were not getting full horsepower. After getting that corrected on Thursday and not solving the problem that requested the dealer to provide coolant temps and supercharger boost. On Friday they provided that information to the Engineers The super charger is only boosting about 3-4psi.
Yesterday a Engineer flew in from Detroit and my Service Advisor told me early afternoon that he had my hawk in the bay and had been on the phone with a laptop in his hand for about 3 hours. They also ordered me a new key fob as there seems to be a very small chance it is a bad key fob. (On a side note a key went missing somewhere along they way so the selling Dealer ordered a new one which is due to arrive tomorrow.) The key fob arrived too late today to the servicing dealer to program it before closing so they will try that in the morning and the Engineer is still in town trying to solve this issue.
My mother in law may still be right, the only trackhawk with less power than a GCSRT and lower than my 300srt...
 

·
Registered
Joined
·
501 Posts
Domn8r: Sorry to hear you're having to deal with that saga. At least someone from engineering is there on the ground with you. That's the right thing for them to do (at the very least) but is more than I might have expected from FCA.
Keep us updated. Full boost feels too good to be missing out on.
 

·
Super Moderator
Joined
·
224 Posts
Sorry to hear you are going through this but does look like the engineers are truly interested in finding the issue and fixing it, hope the saga ends soon!

They also ordered me a new key fob as there seems to be a very small chance it is a bad key fob. (On a side note a key went missing somewhere along they way so the selling Dealer ordered a new one which is due to arrive tomorrow.)
I find this very interesting.

A few times the question has come up on IF we could get a black fob and run with lowered power as they do in the Hellcat cars. I don't think many of us WANT to do that but I have been curious if it would work. I know it can be done through valet mode but could definitely see the appeal of having a fob automatically drop the power, especially if I had a kid just learning to drive.

Again, hate to hear of your problems but this does seem to confirm that some programming might reside in there that could drop the power with certain fobs, although I assume they had ordered a red one to begin with so still crazy that it would have done it.
 

·
Registered
Joined
·
361 Posts
If this goes on much longer (like maybe just a few more days) I think I'd ask them for a replacement vehicle swap and then they can work on yours (theirs :grin2:) as long as they want back at the factory. I'm glad they seem to be going the extra mile but this has been dragging on long enough. At some point enough is enough.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #17
Good News, They fixed it, and I got it back Wednesday. The warrantied key fob and a software adjustment fixed the problem. I won't miss the rental Durango's six cylinder...lol
 

·
Registered
Joined
·
501 Posts
What a clusterfukk. Sorry you had to go through all that!
 
1 - 20 of 105 Posts
Top