Jeep TrackHawk Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Gents, it's freakin' -26° here. The fan behind my radiator is always running within 2 blocks of leaving my house, work, whatever, no fail. I let it warm up for 5 minutes then go on my way. Is this normal? Only mod is LMI. Scrolling through, intake temp was 80°, oil temp was 59°, engine temp needle barely moved up 1/4 way. Everything was cold, just went a few blocks to the gas station tonight to top off, but this happens every time I drive. Is something wrong? Are there fan settings? Dealership visit in order? It's driving me nuts. How are everyone else's fans operating? Thanks.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
***UPDATE***
Lately I've been spending a lot more time switching from street to sport to track modes and identifying the different characteristics while driving. This morning while sitting at the bus stop with my daughter, I started messing around with the dial absentmindedly. Fan kicked on when I selected sport mode. I was just sitting there idling, car only ran about 5 minutes. When I switched back to street mode, fan shut off. Same situation for track mode while parked...Custom too.

After my daughter got on the bus, I tooled around the neighborhood at slow speeds just to test this and yes, the fans kicked on on every mode except street. I guess I answered my own question. The TH must be programmed to kick on fans in preparation for being flogged in Sport, Track and Custom, which is nice to know, I just didn't know or read that.
 
1 - 3 of 3 Posts
Top