Jeep TrackHawk Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
I think that I may have seen a post here a while ago about the onboard dyno and actual hp. Not sure how accurate it is, but now that I started looking I have not been able to get it above 600 hp. Even at a launch in track mode. Shouldn't launch in track mode hit the highest hp available?

I was able to get some 0-60's under 3.5 (a few at 3.1) during the spring was not looking at the dyno back then. Could it be the 90 degree heat or is this something I should be going to the dealer for? Have not been able to get a great 0-6 since it got warm. All above 3.8 to 5.0.

On another note when I log into this forum I see this "Your Notifications 6Subscriptions", I have no idea wht the "6" is as if I click on notifications and subscriptions nothing shows. Anyone have a clue on this?
 

·
Registered
Joined
·
412 Posts
It's been 95-100^ here in N. Dallas for 3 weeks... and mine is showing right at 600hp/tq at best and I'm seeing 0-60 in 3.5-3.6.

I don't know if the on-board dyno is actual or rear wheel... as long as I run the times, I don't care. I bought mine in May, and haven't run it in less than 80^F heat and my best 0-60 time is 3.4. I'm hoping for 3.2s or so once we get into fall and winter. :)
 

·
Registered
Joined
·
594 Posts
What do you guys who run TH tuning shops with chassis dynos say about the accuracy of the TH's onboard dyno?

What's real-world wheel hp and torque for a sampling of totally stock THs?
 

·
Registered
Joined
·
28 Posts
I've had the opportunity to push my accelerator to the floor on a couple occasions in 90 degree weather, in sport mode and with a/c off; the highest I could get my HP to show on the performance page was 579 horses

When it hit 579 the gear shifts and I drop to 440 horses and rise from there back to 579 quickly.

Is this typical? and when the manufacturer states 707 HP, I assume that's at the flywheel.

Can anyone reach this 707 HP target?
 

·
Registered
Joined
·
15 Posts
I've had the opportunity to push my accelerator to the floor on a couple occasions in 90 degree weather, in sport mode and with a/c off; the highest I could get my HP to show on the performance page was 579 horses

When it hit 579 the gear shifts and I drop to 440 horses and rise from there back to 579 quickly.

Is this typical? and when the manufacturer states 707 HP, I assume that's at the flywheel.

Can anyone reach this 707 HP target?
Same. I’ve seen no changes since back in the summer when I first noted that the performance pages were only showing in and around the 600 hp Mark. I’ve had an opportunity to do some launching at 10°C, and there has been a marginal improvement in my times. My fastest time yet is still 3.7, but every other time is between 3.8 and 4.1. It seems to me that there are a few people here quoting times of 3.2 seconds, I don’t know that mine will ever produced that number. I finally did get the brakes to hold for launch, but it still always reads launch aborted at the end. Mine is nearly due for an oil change, which was FCA’s response to my questions. They told me to come back when I have 5000 km on the odometer and we will review the performance.
 

·
Registered
Joined
·
29 Posts
Check boost If you are seeing over 10 lbs you are fine. 11.6 is what is advertised
 
1 - 7 of 7 Posts
Top