Jeep TrackHawk Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter #1
Hey guys,

So, I'm sitting at a left turn light one day with my son. The light turns green and I start moving forward to turn left and I punch the throttle, expecting it to launch real quick to get some sideways spin to excite my 15 year old son. As soon as I punch it, the TH falls on it's face, so now we are pretty much straightened out on the road and I punch it again and it goes this time. I was like....hmmm... that was weird. Is there some sort of safety setup that when you're in normal drive mode, it senses the front wheels are turned some in a slow turn moving and it cuts power briefly for safety reasons?

Anyone ever experience anything like this before? Fuel tank was nearly full btw, so it shouldn't have been a fuel starvation issue.

Thanks
 

·
Super Moderator
Joined
·
1,665 Posts
If you’re modified, you gotta be in track mode or the nanny kills the power, feels a lot like traction control kicking in
 

·
Registered
Joined
·
345 Posts
With my first TH (2018 model), it cutout several times under WOT 1/4 mile runs when running under 1/4 tank of gas. It never happened with more than 1/2 tank.... Pretty clear to me it was fuel starvation. Sometimes I'd feel the rev limiter kick in (very slightly) between shifts on WOT runs too. But never had it totally cutout.

With my second TH (2019 model), it has cutout "twice" on WOT starts similar to what you described. I'd be in track mode and launch it. About a sec later it would go to idle but I still had my foot on the floor. (WTF!) I'd wait a few sec's and hit it again and all was okay. This hasn't happen again in the past 6 months (or 10k miles) so I haven't been able to figure out why. (And I have tried to replicate it:laugh:, many times)
 

·
Super Moderator
Joined
·
945 Posts
Hey guys,

So, I'm sitting at a left turn light one day with my son. The light turns green and I start moving forward to turn left and I punch the throttle, expecting it to launch real quick to get some sideways spin to excite my 15 year old son. As soon as I punch it, the TH falls on it's face, so now we are pretty much straightened out on the road and I punch it again and it goes this time. I was like....hmmm... that was weird. Is there some sort of safety setup that when you're in normal drive mode, it senses the front wheels are turned some in a slow turn moving and it cuts power briefly for safety reasons?

Anyone ever experience anything like this before? Fuel tank was nearly full btw, so it shouldn't have been a fuel starvation issue.

Thanks
you have AWD you are not getting sideways.
I agree with the rest of guys most likley the TC kicked in.
side note auto is never in the right gear switch it to sport. or set up a custom setting. I like softer suspension but no TC and firm shifts. you can play with what ever you want. or find one on here and copy it.
 

·
Super Moderator
Joined
·
945 Posts
Idk, I’ve done some pretty respectable power slides in this thing (for a Jeep)
you must have been really trying hard? I think to impress his kid would be a straight up launch where he could feel the Gs push him in the seat. my kids love it, they always say more but I am to old to be acting stupid with kids in car so just lil blast and thats it.
 

·
Super Moderator
Joined
·
1,665 Posts
Track mode on a slick road. I know it’s cheating but I didn’t think i would even be able to pull it off with as slow as the steering is. I was wrong
 

·
Registered
Joined
·
186 Posts
Discussion Starter #11
I agree that maybe it could have been the TC kicking in, but it never even took off until I dipped into it for a second time. It was just really odd, like you hit the throttle and nothing happens, let out and hit it again and it takes off.
 

·
Registered
Joined
·
4 Posts
Its happened to me as well three times now, but only after being modified, never had this issue when it was stock.

Each time was in Sport. The first time was fairly late in a straight line pull. Just cut off/fell on its face for a couple seconds, then I was able to accelerate again. This was with traction control on.

Second time was with traction control on again, I did a quick hard accel lane change from a low speed, cut out as I jumped in the other lane.

Third time was in Sport again but with traction control off this time (but I'm unsure if its turned off completely just bv pushing the button to turn it off). This time was dangerous, I did a quick lane change to jump in front of a slow truck as the gap in my lane was closing to get out of it. It cut out for a couple seconds right as I jumped in front of the truck in the other lane. My speed was high enough that it wasnt an issue, but gives me pause now on making quick lane changes in traffic.

My tuner has assumed its something to do with traction control, but Im still trying to get a good log of it. I was able to get a log of the last time it happened, but didnt have all of the correct channels for HPtuners set up. Its so random when it happens, but hopefully I can replicate it again and see if it shows anything meaningful in the log.

Since it happened the first time late in a straight line pull, this is where it doesnt make as much sense to assume traction control. Tank was at least 3/4 full on the first one, dont recall on the other two but I dont really let it get below 1/2 tank too often since there is only one e85 station in town and its not always easy to get a spot, so I fill whenever I pass by and see an open spot. Im flex fuel, but haven't put 91 back in this since the tune, e85 is too much fun.
 

·
Registered
Joined
·
126 Posts
Track mode on a slick road. I know it’s cheating but I didn’t think i would even be able to pull it off with as slow as the steering is. I was wrong
You really think that the steering is slow?!? You must have roads with much sharper corners than I do.
 

·
Registered
Joined
·
186 Posts
Discussion Starter #14
Its happened to me as well three times now, but only after being modified, never had this issue when it was stock.

Each time was in Sport. The first time was fairly late in a straight line pull. Just cut off/fell on its face for a couple seconds, then I was able to accelerate again. This was with traction control on.

Second time was with traction control on again, I did a quick hard accel lane change from a low speed, cut out as I jumped in the other lane.

Third time was in Sport again but with traction control off this time (but I'm unsure if its turned off completely just bv pushing the button to turn it off). This time was dangerous, I did a quick lane change to jump in front of a slow truck as the gap in my lane was closing to get out of it. It cut out for a couple seconds right as I jumped in front of the truck in the other lane. My speed was high enough that it wasnt an issue, but gives me pause now on making quick lane changes in traffic.

My tuner has assumed its something to do with traction control, but Im still trying to get a good log of it. I was able to get a log of the last time it happened, but didnt have all of the correct channels for HPtuners set up. Its so random when it happens, but hopefully I can replicate it again and see if it shows anything meaningful in the log.

Since it happened the first time late in a straight line pull, this is where it doesnt make as much sense to assume traction control. Tank was at least 3/4 full on the first one, dont recall on the other two but I dont really let it get below 1/2 tank too often since there is only one e85 station in town and its not always easy to get a spot, so I fill whenever I pass by and see an open spot. Im flex fuel, but haven't put 91 back in this since the tune, e85 is too much fun.
Thanks for the input here. Mine is bone stock besides the JLT intake btw.
 
1 - 15 of 15 Posts
Top