Jeep TrackHawk Forum banner

21 - 33 of 33 Posts

·
Registered
Joined
·
53 Posts
Well happy to report back that they installed the new valve body in my transmission and the Trackhawk feels awesome. Maybe I didn’t realize how sluggish my transmission originally was. No more lag on take off and shifts gears effortlessly when pressing the gas. Feels like a brand new vehicle. If you guys are having this problem, highly recommend you suggest this as a fix. According to the receipts it was about a $3,800 fix.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
78 Posts
Awesome you had yours fixed. Even better that the warranty covered that bill! I’ll def go have mine checked out. Think I may have the same issue.
 

·
Registered
Joined
·
411 Posts
$3800 for a valve body and install? That is crazy.

Glad you're taken care of!!
 

·
Registered
Joined
·
53 Posts
Thanks! Jeep feels brand new, love it. Its actually downshifting like it’s supposed to even at higher speeds. Usually around 80mph, punching it at full throttle would only down shift one gear or so, now it drops down multiple gears immediately. More power delivery feel now in the right rpm range. Makes me feel like mine was screwed up from factory.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
78 Posts
Thanks! Jeep feels brand new, love it. Its actually downshifting like it’s supposed to even at higher speeds. Usually around 80mph, punching it at full throttle would only down shift one gear or so, now it drops down multiple gears immediately. More power delivery feel now in the right rpm range. Makes me feel like mine was screwed up from factory.


Sent from my iPhone using Tapatalk

Another reason to add to my list hah. Sometimes mine lags to drop a gear or two when I’m in 8th and it drives me crazy...Started really noticing it a couple weeks ago. Finally scheduled a appointment at my local Jeep dealership next Wednesday. But ofcourse with my luck, weather forecast is all snow next week lol.
 

·
Registered
Joined
·
70 Posts
I just heard back from dealership on mine. Thank goodness it did it for them on their test drive. They quickly identified it as the valve body in the transmission needing replaced and orders a new one. They indicated there’s a bulletin out on this but I haven’t seen it.


Sent from my iPhone using Tapatalk
Can you check on your receipt from the dealership on what the bulletin number was and post it here? It should be clearly labelled on there. I have to take mine in soon for a similar symptom and wanted to make sure that I can at least give them something to look for in case.

If you are able to it would be very much appreciated!
 

·
Registered
Joined
·
70 Posts
I was informed of a bulletin for the trans, but won’t be able to get the info until I get the truck back.

I have small exhaust leak due to broken bolt in manifold, and the gaskets are FIVE DAYS OUT !
 

·
Registered
Joined
·
70 Posts
Well, got the ‘Hawk back after ten days at the dealer. Supercharger and head gaskets are apparently in short supply.

The trans flash performed seems to have improved drivability substantially. I’ll report back after the learned adaptations settle, but I’m cautiously optimistic at present.
 

·
Registered
Joined
·
34 Posts
I’m still having this issue. When I change the display to show current gear, no matter the drive mode, there is a very slow lag from 2nd to 1st when approaching a stop sign. When I punch it (even slightly) the trans is still in 2nd and then drops to 1st, resulting in the sudden lurch forward. It remains very annoying. I did bring it in last December for oil change and mentioned the issue, but the explanation I got was detonation because I was using bad gas. Nope! Only 93 has ever touched the injectors, but I have been too busy to argue with the dealership. Perhaps it’s time to go back in...ughh.
 
21 - 33 of 33 Posts
Top