Jeep TrackHawk Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2019 trackhawk. A handful of times I went to drive the Jeep and no lights, no power. Symptoms of a totally dead battery. Happened the morning after we brought it home. The dealer changed the battery. Was fine for a while and since it has happened 2-3 more times. Got it towed to the dealer again this past Wednesday. Anybody have similar issues or know what is going on? Absolutely love the truck but for the money I shouldn’t have this issue. It only has 5k miles. Tempted to go the lemon law route if I have to....
 

·
Super Moderator
Joined
·
2,294 Posts
I’d take a breath first. If it’s no lights then there’s an electrical issue somewhere. Probably just a connection that’s not fully seated. Before you go the return route try another dealership if you can. I’ve had a miserable time trying to deal with FCA, good luck with them.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It’s at the second dealership for the second time. Hopefully they find d sad one thing this time. As of now it’s a crap shoot if it will start or not. I escalated the issue to Jeep headquarters. We will see if that makes a difference
 

·
Super Moderator
Joined
·
2,294 Posts
Best of luck. I know how frustrating it can be. Do you have a HP tuners MVPI2? Maybe you can see something with that.
 

·
Registered
Joined
·
220 Posts
Is it a dead battery? Or low voltage due to something draining it? Somewhere posted hear I think someone had a similar issue and as I recall it was the intercooler pump that would come on intermittently and drain the battery.
 

·
Registered
Joined
·
65 Posts
Hope they can figure it out quickly. Basic connections, cleaned battery terminals. Somewhere where water could have gotten in.
 

·
Super Moderator
Joined
·
2,294 Posts
That’s a good point. These things have iffy batteries to begin with. Does a jump start not work? Maybe you do have something killing it.If you can, get a MVPI2, put it on is tender and log it all night, see what happens.
 

·
Banned
Joined
·
391 Posts
Mine doesn't like sitting for long, I've noticed.
Seems that the lights by the USB ports never go off, for example. Time for a good solar panel setup, I guess.
 

·
Super Moderator
Joined
·
1,420 Posts
the batterys are not the greatest thats for sure. I have a small led light that will drain the battery if left more then 3 days. at 3 days the car wont auto start as its to low have to get in and start (happened today) its the smallest **** LED light ever for my intercooler but drains the battery so fast.

same thing happens in my Impalas the stereo has a flashing LED light and will kill the battery (Optima) in 4 or so days. I have a batter kill switch for winter storage and a tender hook up for summer in both.
 

·
Registered
Joined
·
65 Posts
After shipping the TH here to Germany I had a no start situation after the first night. Shipping took 45 days. I placed a battery maintainer/charger on over the weekend and haven't has a problem since. Although the charging system typically shows 14.4 volts, it seems like they need a fully charged battery with all the electronics.
 

·
Registered
Joined
·
386 Posts
2019 trackhawk. A handful of times I went to drive the Jeep and no lights, no power. Symptoms of a totally dead battery. Happened the morning after we brought it home. The dealer changed the battery. Was fine for a while and since it has happened 2-3 more times. Got it towed to the dealer again this past Wednesday. Anybody have similar issues or know what is going on? Absolutely love the truck but for the money I shouldn’t have this issue. It only has 5k miles. Tempted to go the lemon law route if I have to....
FWIW, I had a similar issue and they discovered that one of my USB ports in the dash (in front of the shifter) never shut off. I had a thumb drive with music on it plugged in so I could switch to the USB port and listen to my downloaded music. Eventually, after several days, my truck was dead. They replaced the entire USB console and I haven't had the issue since. And yes, I still have my thumb drive plugged in.
 

·
Registered
Joined
·
10 Posts
Battery Grounding

Sounds like it could be a grounding issue. Check the connection between the grounding wire from the battery and where it connects to the frame of the vehicle.
 

·
Registered
Joined
·
99 Posts
I haven't had a starting issue but I did have an issue with the battery light coming on. The dealer changed the battery and alternator and it' been fine since. That was about 5,000 miles ago.
 
1 - 13 of 13 Posts
Top